Commit 360f89fe authored by garcialasheras's avatar garcialasheras

adding spec software project support

parent c1dbd2cf
SUMMARY = "Provides wr_nic_dio.bin bitstream for wr-nic over spec"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
inherit module
PR = "r0"
PV = "0.1"
SRC_URI = "http://www.ohwr.org/attachments/download/2687/wr_nic_dio.bin-2014-02-14"
SRC_URI[md5sum] = "371f22659e5acf8612e7e11c1481abf6"
S = "${WORKDIR}/"
FILES_${PN} += "/lib/firmware/fmc"
do_compile() {
:
}
do_install() {
install -d ${D}/lib/firmware/fmc
install -m 0755 ${S}/wr_nic_dio.bin-2014-02-14 ${D}/lib/firmware/fmc/wr_nic_dio.bin
}
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
SUMMARY = "Provides wr_nic_dio-wrc.bin LM32 soft processor firmware for wr-nic over spec"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
inherit module
PR = "r0"
PV = "0.1"
SRC_URI = "http://www.ohwr.org/attachments/download/2688/wr_nic_dio-wrc.bin-2014-02-14"
SRC_URI[md5sum] = "b612220a0704d78d38fdc4ceed2094d3"
S = "${WORKDIR}/"
FILES_${PN} += "/lib/firmware/fmc"
do_compile() {
:
}
do_install() {
install -d ${D}/lib/firmware/fmc
install -m 0755 ${S}/wr_nic_dio-wrc.bin-2014-02-14 ${D}/lib/firmware/fmc/wr_nic_dio-wrc.bin
}
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
SUMMARY = "Provides spec_init.bin golden bitstream for default boot time FPGA configuration"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
inherit module
PR = "r0"
PV = "0.1"
SRC_URI = "http://www.ohwr.org/attachments/download/1756/spec-init.bin-2012-12-14"
SRC_URI[md5sum] = "acc3778d05999ddb23771bac74ec270f"
S = "${WORKDIR}/"
FILES_${PN} += "/lib/firmware/fmc"
do_compile() {
:
}
do_install() {
install -d ${D}/lib/firmware/fmc
install -m 0755 ${S}/spec-init.bin-2012-12-14 ${D}/lib/firmware/fmc/spec-init.bin
}
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
diff -Naur a/Makefile b/Makefile
--- a/Makefile 2014-11-09 06:17:52.657700773 +0100
+++ b/Makefile 2014-11-09 06:19:26.030800405 +0100
@@ -1,13 +1,6 @@
-# We have a problem here: this package may be a submodule of something
-# else (for example: fine-delay). If this is the case, fmc-bus is on ../
-# This external script returns the pathname of the "kernel" subdir of fmc-bus
-FMC_DRV ?= $(shell ./check-fmc-bus)
-export FMC_DRV
-
-RUNME := $(shell test -d $(FMC_DRV) || git submodule update --init)
-
-DIRS = $(FMC_DRV) kernel tools
+# This is a dirty hack: just compile the tools
+DIRS = tools
all clean modules install modules_install:
for d in $(DIRS); do $(MAKE) -C $$d $@ || exit 1; done
SUMMARY = "Provides libspec dynamic library intended for user-space SPEC control"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
inherit module
PR = "r0"
PV = "0.1"
SRC_URI = "git://ohwr.org/fmc-projects/spec/spec-sw.git \
file://makefile-fix.patch"
SRCREV = "aed186b9a3783b1f3763eb0ba64613d536250b9d"
S = "${WORKDIR}/git"
FILES_SOLIBSDEV = ""
FILES_${PN} += "${libdir}/*.so"
do_install() {
install -d ${D}${libdir}
install -m 0755 ${S}/tools/libspec.so ${D}${libdir}
}
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
diff -Naur a/kernel/Makefile b/kernel/Makefile
--- a/kernel/Makefile 2014-11-08 04:17:52.657700773 +0100
+++ b/kernel/Makefile 2014-11-08 04:19:26.030800405 +0100
@@ -1,5 +1,5 @@
-LINUX ?= /lib/modules/$(shell uname -r)/build
+LINUX ?= $(KERNEL_SRC)
FMC_DRV ?= $(shell ../check-fmc-bus)
export FMC_DRV
diff -Naur a/fmc-bus/kernel/Makefile b/fmc-bus/kernel/Makefile
--- a/fmc-bus/kernel/Makefile 2014-11-08 04:36:30.957186266 +0100
+++ b/fmc-bus/kernel/Makefile 2014-11-08 04:50:12.313185206 +0100
@@ -1,5 +1,5 @@
-LINUX ?= /lib/modules/$(shell uname -r)/build
+LINUX ?= $(KERNEL_SRC)
ccflags-y += -I$M/include
SUMMARY = "Full spec-sw support, including user-space tools and spec,fmc,wr-nic kernel modules"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
inherit module
PR = "r0"
PV = "0.1"
SRC_URI = "git://ohwr.org/fmc-projects/spec/spec-sw.git \
file://makefile-fix.patch \
file://makefile-fmc-fix.patch"
SRCREV = "eb9b9d03e3f54657fe29fca93021e2b45380da05"
S = "${WORKDIR}/git"
# Most of spec-sw is in git submodules that still need to be fetched.
do_fetch_extra(){
git submodule update --init --recursive
}
addtask fetch_extra after do_unpack before do_patch
FILES_${PN} += "${bindir}/*"
FILES_${PN}-staticdev = "${bindir}/libspec.a"
do_install_extra() {
install -d ${D}${bindir}
install -m 0755 ${S}/tools/spec-cl ${D}${bindir}
install -m 0755 ${S}/tools/spec-fwloader ${D}${bindir}
install -m 0755 ${S}/tools/spec-vuart ${D}${bindir}
install -m 0755 ${S}/tools/specmem ${D}${bindir}
install -m 0755 ${S}/tools/wr-dio-cmd ${D}${bindir}
install -m 0755 ${S}/tools/wr-dio-pps ${D}${bindir}
install -m 0755 ${S}/tools/wr-dio-agent ${D}${bindir}
install -m 0755 ${S}/tools/wr-dio-ruler ${D}${bindir}
install -m 0755 ${S}/tools/stamp-frame ${D}${bindir}
install -m 0755 ${S}/binaries/fmc-dio-eeprom.bin ${D}${bindir}
}
addtask install_extra after do_install before do_populate_sysroot
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment